Looking good! Slicing and dicing to visualize data in Excel Dashboards

Michael Winecoff
UNC Charlotte
J. Murrey Atkins Library

http://goo.gl/ASN5XT
Objective

To take spreadsheet data and present it visually on an interactive dashboard

Excel dashboards allow you to use tables, charts and other data visualizations to tell a story about your data. After you have set up the initial pivot tables, you create slicers to connect them. This allows the various pivot tables to dynamically sync. You can then drill down and visually show your dean and/or liaisons the fund balances, titles, checkout statistics or other information you would like displayed.
<table>
<thead>
<tr>
<th>Steps</th>
<th>Task</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Create the table</td>
</tr>
<tr>
<td>2</td>
<td>Cleanup the table data</td>
</tr>
<tr>
<td>3</td>
<td>Create the PivotTable</td>
</tr>
<tr>
<td>4</td>
<td>Create the PivotCharts, slicers and connect them</td>
</tr>
<tr>
<td>5</td>
<td>Customize your slicers and dashboard</td>
</tr>
</tbody>
</table>
Dashboards

Allow you to use tables and charts to visualize and present useful information – to tell a story about your data.

Dynamically changes as you update for tables. The dashboards also change as you select various criteria from the slicers.
What’s a PivotTable, Pivot Chart, Slicer and Dashboard?

**PivotTable** – Excel tool that reorganizes and summarizes selected columns and rows of data in a spreadsheet to obtain a desired report. User must refresh the PivotTable to see changes in the table.

**PivotChart and PivotGraph** – Visual representation of a PivotTable. PivotCharts and PivotGraphs update when the PivotTables change.

**Slicers** - Buttons on the Dashboard that enable you to quickly filter PivotTable data. An advantage of slicers is filtering on multiple PivotTables simultaneously. Users can click on the choices rather than use dropdown menus. Slicers only work with PivotTables in Excel 2010 or higher.

A **dashboard** is a visual display of the most important information needed to achieve one or more objectives; consolidated and arranged on a single screen so the information can be monitored at a glance.
<table>
<thead>
<tr>
<th>Title</th>
<th>Fiscal Year</th>
<th>Order Type</th>
<th>Fund</th>
<th>Liaison</th>
<th>Expended</th>
<th>Checkouts</th>
</tr>
</thead>
<tbody>
<tr>
<td>High notes : selected writings of Gay Talese</td>
<td>2016/2017</td>
<td>Approval</td>
<td>NYT Book Reviews</td>
<td>Abby</td>
<td>$17.80</td>
<td>1</td>
</tr>
<tr>
<td>Against Everything : Essays</td>
<td>2016/2017</td>
<td>Approval</td>
<td>NYT Book Reviews</td>
<td>Abby</td>
<td>$23.74</td>
<td>2</td>
</tr>
<tr>
<td>The etymologies of Isidore of Seville</td>
<td>2013/2014</td>
<td>Approval</td>
<td>Judaic Studies</td>
<td>Jenna</td>
<td>$172.53</td>
<td>0</td>
</tr>
<tr>
<td>The ultimate ambition in the arts of erudition : a compendium</td>
<td>2016/2017</td>
<td>Approval</td>
<td>NYT Book Reviews</td>
<td>Abby</td>
<td>$16.02</td>
<td>0</td>
</tr>
<tr>
<td>Curiosity and method : ten years of Cabinet Magazine, 2013/2014</td>
<td>2013/2014</td>
<td>Film</td>
<td>Art &amp; Art History</td>
<td>Jenna</td>
<td>$40.46</td>
<td>1</td>
</tr>
<tr>
<td>Collecting from the margins : material culture in a Latin</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Anthropology</td>
<td>Amanda</td>
<td>$65.60</td>
<td>0</td>
</tr>
<tr>
<td>Engagement and Access : Innovative Approaches for 2015/2016</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$40.05</td>
<td>0</td>
</tr>
<tr>
<td>Interpreting anniversaries and milestones at museums 2016/2016</td>
<td>2016/2016</td>
<td>Film</td>
<td>History</td>
<td>Amanda</td>
<td>$31.15</td>
<td>0</td>
</tr>
<tr>
<td>Micromuseology : an analysis of small independent museums</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$85.28</td>
<td>0</td>
</tr>
<tr>
<td>Museum ethics in practice</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$40.01</td>
<td>0</td>
</tr>
<tr>
<td>Museums, ethics and cultural heritage</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$40.01</td>
<td>0</td>
</tr>
<tr>
<td>Museums, moralities and human rights</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$44.49</td>
<td>0</td>
</tr>
<tr>
<td>Positioning your museum as a critical community asset</td>
<td>2016/2017</td>
<td>Film</td>
<td>History</td>
<td>Amanda</td>
<td>$32.93</td>
<td>0</td>
</tr>
<tr>
<td>Sentient relics : museums and cinematic affect</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$131.20</td>
<td>0</td>
</tr>
<tr>
<td>The language of museum communication : a diachronic</td>
<td>2016/2017</td>
<td>Film</td>
<td>History</td>
<td>Amanda</td>
<td>$81.99</td>
<td>0</td>
</tr>
<tr>
<td>The Politics of Museums</td>
<td>2016/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$77.90</td>
<td>0</td>
</tr>
<tr>
<td>Uncertain images : museums and the work of photography</td>
<td>2014/2015</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$109.95</td>
<td>0</td>
</tr>
<tr>
<td>Engaging the senses : object-based learning in higher ed</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$119.95</td>
<td>1</td>
</tr>
<tr>
<td>Interpreting slavery at museums and historic sites</td>
<td>2014/2015</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$26.66</td>
<td>1</td>
</tr>
<tr>
<td>Living history : effective costumed Interpretation and e</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$25.81</td>
<td>1</td>
</tr>
<tr>
<td>Museums : a history</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$69.70</td>
<td>1</td>
</tr>
<tr>
<td>Museums in the new mediascape : transmedia, participatory</td>
<td>2014/2015</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$104.95</td>
<td>1</td>
</tr>
<tr>
<td>Progressive museum practice : John Dewey and demo</td>
<td>2013/2014</td>
<td>Film</td>
<td>Educational Leadership</td>
<td>Judy</td>
<td>$42.95</td>
<td>1</td>
</tr>
<tr>
<td>Technology and Digital Initiatives : Innovative Approaches</td>
<td>2015/2016</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$40.05</td>
<td>1</td>
</tr>
<tr>
<td>Creating the visitor-centered museum</td>
<td>2016/2017</td>
<td>Film</td>
<td>History</td>
<td>Amanda</td>
<td>$40.01</td>
<td>2</td>
</tr>
<tr>
<td>Fostering empathy through museums</td>
<td>2016/2017</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$40.05</td>
<td>2</td>
</tr>
<tr>
<td>Museums and higher education working together : chart</td>
<td>2013/2014</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$109.95</td>
<td>3</td>
</tr>
<tr>
<td>Museums and social activism : engaged protest</td>
<td>2013/2014</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$44.46</td>
<td>3</td>
</tr>
<tr>
<td>Museums and truth</td>
<td>2013/2014</td>
<td>Approval</td>
<td>Museum Collections</td>
<td>Nicole</td>
<td>$63.10</td>
<td>3</td>
</tr>
<tr>
<td>Museums in motion : an introduction to the history and</td>
<td>2013/2014</td>
<td>Film</td>
<td>History</td>
<td>Amanda</td>
<td>$35.56</td>
<td>6</td>
</tr>
</tbody>
</table>
Cleanup the Table Data

Step 2

1. Normalize the Data – Check for inconsistencies. Have unique values where possible (dates, names, departments, etc.)
   - Sort
   - Find and Replace
   - Spell check
   - Correct improper cases
   - Fix dates and times to be uniform
   - Remove spaces and nonprinting characters using TRIM and/or CLEAN functions
   - Filter your data – Sort & Filter > Filter Click on the down arrow in each column. Look for data inconsistencies. This is helpful in cleaning up dates, categories and other controlled vocabularies

2. Eliminate blanks
   - Find and Select > Go To Special > Blanks
   - Click on the Fill Color to highlight the blank cells for easier discovery.
   - Sort the column by color – Custom Sort > Sort by (column) > Sort On > Cell Color

3. Remove duplicates
   - Data > Remove Duplicates on the Data Tools tab > Unselect All
   - Select a column with desired unique values like barcodes and OCLC numbers
1. Click the Insert tab > PivotTable on the Tables tab.

2. Assure that the range selected is the entire table. The moving dashes around the table signifies the selection.

3. Place each PivotTable on a New Worksheet to aid in location. Rename the tab appropriately for future reference. This is helpful if you need to edit the PivotTable.

4. Drag the fields from the top to the lower half of the PivotTable Fields box.

Note: Reorder the PivotTable fields within the ROWS box up or down to manipulate your data results. Experiment!

Note: Should your PivotTable Fields disappear from the right side of the screen, simply click inside of the PivotTable.
Create PivotCharts, Slicers and Connect Them **Step 4**

1. **Create the PivotCharts**
   - Click anywhere in the PivotTable to show the PivotTable Tools on the ribbon
   - Click Analyze > PivotChart
   - Click the chart type and chart subtype
   - Copy the PivotTable and PivotChart to the Dashboard tab

2. **Create the slicer**
   - Click on the pivot table. Click on the Analyze tab -- Insert Slicer.
   - Check the data you want to filter
   - Copy the slicers to your Dashboard
   - Perform the above for each PivotTable

3. **Connect the slicers if you have multiple PivotTables**
   - Right click on a slicer -- Report Connections
   - Check each PivotTable listed. This connects them
   - Do this for each slicer. If you later add additional slicers they will need to be connected in this same manner

   This will allow the various PivotTables and slices to work in tandem

   **Result:** Now the slicers change for all pivot tables at the same time
1. **Create a slicer style to create a uniform appearance**
   - Hold the Shift key and click on the desired slicers you wish to customize
   - Click the Options tab and then the arrow in the Slicer Styles section
   - Select a style to apply selectively or to all
   - You can additionally apply separate styles to each slicer

   Optionally you can create a *new, custom slicer style*
   - Click on the arrow in the Slicer Styles section
   - Select New Slicer Style
   - Select the Slicer Element you wish to customize
   - Format the Font, Border and Fill color for each element if desired

   **Important:** To apply your custom style you will need to select the slicers and click on the arrow in the Slicer Styles section and select Custom in the top section.

2. **Slicer caption names**
   - Remove/rename the display name
   - Right click on slicer > Slicer settings
   - Check/uncheck **Display header** and change the caption if desired

3. **Slicer columns**
   - Change the number of slicer columns to accommodate more/less choices
   - Slicer Tools > Options > Buttons > Columns
Tips on Using the Dashboard, PivotTable and Slicers

1. **Select elements in your slicer**
   - Click individual elements
   - Drag the mouse button to select tangent elements
   - Ctrl-click on multiple elements in the list

2. **Deselect elements in your slicer**
   - Ctrl-click on the individual elements you wish to eliminate from your filter
   - Click on the red X in the upper corner of the slicer to deselect all elements in the slicer

3. **Alphabetize results**
   - Right-click on the slicer
   - Select Slicer-settings
   - Select Ascending (A to Z)

4. **Excel Suggested PivotTables**
   - Click on the PivotTable
   - Select Recommended PivotTables on the Analyze tab

5. **Updating your Dashboard**
   Updating your table with new data does not automatically update your dashboard!
   - Right-click on the PivotTable
   - Select Refresh. To update all PivotTables in the workbook click the Refresh button arrow and then click Refresh All
   - You can also select any cell in the PivotTable and use the keyboard shortcut ALT + F5